وبلاگ

بخش مجله خبری ‌‌‌، بروز رسانی ، اخبار و دیگر خبرها مهم سایت

php7 سریعترین نسخه php در حال حاضر می باشد که می تواند سرعت سایت جوملایی شما را تا 50% افزایش دهد .

خوب شاید تا الان به ذهنتان رسیده باشد که اگر نسخه php سایت خود را به آخرین نسخه یعنی php7 بروزرسانی کنید ، مشکلی برای سایت جوملایتان پیش خواهد آمد یا خیر .

توضیحات پی اچ پی

پی اچ پی زبان برنامه نویسی سمت سرور می باشد بنابراین زبان برنامه نویسی پی اچ پی نیاز به استفاده از سرور دارد .

استفاده از پی اچ پی در جوملا به توسعه دهندگان اجازه میدهد که به طور پویا HTML ایجاد کنند و با یک پایگاه داده ارتباط برقرار و از فرآیندهای پیچیده دیگر استفاده کنند .

بنابراین جوملا نصب شده از پی اچ پی استفاده می کند ولی آنرا نصب نمی کتد ، در عوض پی اچ پی روی سرور نصب شده و توسط شرکت های میزبانی اجرا می شود . بنابراین جوملا وابسته به یک محیط سرور است که درخواست های پی اچ پی را طراحی و پردازش می کند .

برای بروزرسانی php7 در سرور باید موارد زیر را اعمال کنید .

مرحله 1 به روز رسانی به جوملا 3.9

برخی از نسخه های قدیمی تر جوملا (قبل از جوملا 3.5) پی اچ پی 7 را پشتیبانی نمی کنند. با این حال، نسخه های جدیدتر جوملا دارای سازگاری داخلی با پی اچ پی 7 می باشند . بنابراین برای استفاده از آن، برای اولین بار به جوملا 3.9 به روز رسانی کنید .

مرحله 2 به روز رسانی افزونه ها ( الحاقات جوملا )

پس از به روز رسانی نسخه جوملا، به روز رسانی افزونه های جوملا پیشنهاد می شود . و مشکلات با نسخه جدید پی اچ پی را کاهش و سازگاری را تضمین می کند.

مرحله 3 درخواست از میزبان خود برای انجام به روز رسانی به پی اچ پی7

همانطور که در قسمت اول توضیح داده شد، پی اچ پی بر روی سرور نصب شده و اجرا می شود. بنابراین، برای به روز رسانی پی اچ پی، باید در سطح سرور انجام شود.

در نتیجه، ساده ترین راه این است که از پشتیبانی شرکت میزبانی خود بخواهید که این کار را برای شما انجام دهد. اکثر میزبانها قادر خواهند بود به روز رسانی را به سرعت انجام دهند. هرکدام دیگر به احتمال زیاد اسناد را برای تنظیم خاص خود ارائه خواهند داد.

اگر بعد از به روز رسانی، هر گونه مسائل و مشکلات را مشاهده کردید ، می توانید از آنها بخواهید که به نسخه قبلی خود نسخه PHP بازگردند. این یک تغییر ساده است، بنابراین شما می توانید به عقب و جلو بروید.

گروه طراحی خلیلان رسانه به مشتریان خود برای به روزرسانی به php7 کمک خواهد کرد .

لطفا در صورت نیاز می توانید درخواست خود برای به روز رسانی به php7 را اعلام ، تا مراتب در ادامه به حضور اعلام گردد .

 

 

شما در سایت وردپرسی خودتون اروری دریافت کردید که با این متن هست :

Warning: Cannot modify header information - headers already sent by (output started at



یا به این شکل :

Cannot modify header information - headers already sent by (output started at /path/blog/wp-config.php:37)



همان طوری که میبینید ارور فایل و خط مورد نظر رو به ما معرفی میکنه و کار برای برطرف کردن ارور راحت تر است.


البته شاید در فایل های دیگه هم همین مشکل ایجاد شود و این فقط بعنوان نمونه می باشد .

جای نگرانی نیست و این مشکل قابل حل است

علت های این ارور رو بررسی میکنیم :

یکی از معمول ترین دلیل های این ارور فاصله بین تگ شروع و پایان php هست :
<?php
 
 
  ?>
در فایل wp-config.php چک کنید که هیچ فاصله ای بین کد ها نباشه و فضای خالی نباشه

البته ممکنه این ارور مربوط به فایل دیگه ای هم بشه که در انتهای ارور میتونید فایل مربوطه رو ببینید

گاهی اوقات ممکنه شما ببینید که در فایل مربوطه همی چی درسته ولی php مثل شما نمیبینه

برای اینکه از این بابت مطمئن بشیم فایل مربوطه رو از ftp یا کنترل پنل هاست دانلود میکنیم (دقت کنید کدها رو کپی نمیکنیم و فقط دانلود میکنم)

فایل دریافتی رو با نرم افزار notepad++ باز کنید

حالا چک کنید که هیچ فضای خالی بین تگ پی اچ پی نباشه و بعد قبل از اینکه فایل رو save کنید مثل تصویر زیر encoding رو روی utf8 without bom بزارید و بعد ذخیره کنید

 

 
حالا فایل رو بر روی هاست آپلود کنید و جایگزین فایل قبلی کنید

99 درصد موارد با از بین بردن فضای خالی و تغییر اینکدینک برطرف می شود
 

با سلام خدمت تمامی دوستان عزیز

فیلم آموزش نصب قالب خبری ناب نیوز برای وردپرس بصورت بسته نصبی

لطفا نظرات خود را در مورد فیلم آموزشی نصب قالب خبری ناب نیوز بر روی وردپرس بیان کنید .

آموزش فیلم قالب ناب نیوز | قالب ناب نیوز | قالب ناب نیوز وردپرس | قالب خبری | قالب خبری وردپرس | قالب وردپرس | فیلم آموزشی وردپرس | آموزش قالب | طراحی قالب

 

فیلم آموزشی نصب قالب خبری ناب نیوز بر روی وردپرس پیشفرض

با تشکر

موفق و پیروز باشید .

[fancy_text tags="در این آموزش قصد داریم نصب بسته های نصبی وردپرس (کویک استار) با افزونه Duplicator را به شما عزیزان آموزش دهیم" type="1" class="template-style"].

بسته نصبی یا کویک استار چیست : یک پکیج وردپرس می باشد  که شامل خود وردپرس ، قالب ، افزونه ها و محتویاتی مانند عکس ها می باشد . وقتی این بسته را نصب کنید سایتی همانند دمو خواهید داشت .

دیگر با وجود بسته نصبی شما  دقدقه نصب قالب و ایمپورت کردن و تنظیمات قالب که هم زمان بر است هم امکان خوردن به مشکل وجود را ندارید

برای نصب ابتدا باید یک دیتابیس ایجاد کنید ، حال شما باید ابتدا بسته ای وردپرس را در روت هاست (public_html) یا ساب دامنه یا فولدری که می خواهید نصب کنید ، آن را آپلود کنید . بعد از آپلود فایل آن را اکسترک کنید وقتی آن را اکسترک کنید.
[note type="success" icon="yes" class="template-style"]بعد از اکسترک دو فایل موجود می باشد یک فایل بصورت زیپ شده از قالب بهمراه دیتابیس و یک فایل با نام installer.php . [/note]
خوب حالا اسم دامنه خود را برای نصب در مروگر وارد کنید و در آخر اسم دامنه خود installer.php/ را اضافه کنید تا مراحل نصب برای شما ظاهر شود .


در قسمت MySQL Database در قسمت Action شما باید حالت را روی گزینه Conncet and Remove All Data انتخاب کنید .
در قسمت Name شما باید نام دیتابیس خود را وارد کنید ، در قسمت User می بایست نام کاربری دیتابیس خود را درج کنید و Password هم که باید رمز عبور خود را انتخاب کنید .
زمانی که اطلاعات دیتابیس خود را وارد کردید بر روی دکمه Test Connection کلیک کنید اگر پیغام Success به شکل سبز رنگ برای شما آمد یعنی اتصال شما به دیتابیس با موفقیت آمیز بوده در غیر اینصورت شما حتما باید اطلاعات را چک کنید.
حال باید  تیک قوانین را I have read all warnings & notices را بزنید و بر روی دکمه Run Deployment بزنید تا وارد مرحله بعدی شوید.
در مرحله بعدی با صفحه ای همانند عکس زیر مواجه خواهید شد


در این مرحله شما باید در قسمت New Admin Account در قسمت username و password باید نام کاربری و رمزعبور وردپرس خود را به آن دهید.
در محله آخر روی دکمه Run Update کلیک کنید تا به مرحله آخر بروید .


تبریک میگم شما بسته نصبی وردپرس را نصب کردید حالا بر روی Test Site کلیک کنید تا سایت برای شما همانند نمونه نمایشی ما باز شود .
موفق و پیروز باشید .